Features of !SEMTools

Excel ұяшықтарындағы таңбалар санын санау өте пайдалы болуы мүмкін – жалғыз сұрақ қандай нақты алгоритмді пайдалану керек. Ал бұл, өз кезегінде, тапсырманың жағдайы мен шарттарына байланысты.

Ұяшықтардағы таңбаларды санау қажет болғанда

Көбінесе ұяшықтағы барлық немесе белгілі бір таңбалардың саны қандай да бір шектеулер болған кезде белгілі болуы керек:

  • әрбір ұяшықтағы таңбалар саны белгілі бір мәннен аспауы керек
  • ұяшықтардың ұзындығына шектеу жоқ, бірақ бірнеше таңбалардың жалпы санына шектеу бар
  • төмендегі таңбалар санына шектеу болған кезде, басқаша айтқанда, ең аз ұзындық
  • ұяшыққа енгізілген белгілі бір таңбалар санына шектеу бар (мысалы, бір «!» таңбасынан артық емес)

Төменде мен әрбір жағдайды толығырақ қарастырамын.

Әрбір ұяшықтағы таңбалар санын есептеңіз

Сіз формуланы да, Excel процедураларын да пайдалана аласыз.

Ұяшықтағы таңбалар саны – формула

DLSTR тамаша мүмкіндік және оны ұяшықтардағы таңбаларды санауға қатысты көптеген тапсырмаларды шешу үшін пайдалануға болады. Міне, оны қолданудың қарапайым мысалы.

Формула келесідей көрінеді:

=ДЛСТР(A1)
image-28
Формуланың нәтижесі

Ұяшықтардағы таңбаларды санау тәртібі

Формулаларды енгізу күрделі жұмыс болғандықтан, мен Excel қондырмасында осы тапсырма үшін қарапайым процедураны жасадым. Процедураның сұлулығы мынада, ол бірнеше рет басу арқылы барлығын бірден есептейді және нәтижені оң жақтағы бағанға көрсетеді (егер көрші бағанға шығару опциясы белсенді болса).

Сіз бүкіл бағанды ​​таңдай аласыз, қондырманың өзі жұмыс ауқымының соңын анықтайды:

количество-символов-в-ячейках
!SEMTools процедурасы арқылы бірнеше ұяшықтардағы таңбалар санын санау

Бір уақытта бірнеше ұяшықтағы таңбалар санын санау

Ұяшықтардың әрқайсысының мазмұнының ұзындығын есептеу тапсырмасы болмаса, бірақ ұзындықтардың қосындысы бірден қажет болса, сіз бірдей DLSTR функциясын пайдалана аласыз, бірақ сәл басқа пішінде – массив түрінде. формула:

image-29
Таңбалардағы бірнеше ұяшықтар мазмұнының жалпы ұзындығын есептеу формуласы

Формула мәтіні:

=СУММ(ДЛСТР(A2:A6))

Формула Ctrl + Shift + Enter пернелер тіркесімін пайдаланып ұяшыққа енгізгеннен кейін бұйра жақшаларды алған жағдайда ғана дұрыс нәтиже беретінін түсіну маңызды.

Белгілі бір таңбаның ұяшықта неше рет кездесетінін санаңыз

Белгілі бір таңбалы және бірдей ұяшықты, бірақ онсыз ұяшықтың ұзындықтарының айырмашылығын есептесек, бұл таңбаның ұяшықта пайда болуын аламыз.

SUBSTITUTE функциясы таңбаны жоюға көмектеседі, бірақ мұнда ұяшықтардағы «y» әрпін санау мысалын қолданатын күрделі формула берілген:

image-30
Ұяшықтағы «у» әрпінің кездесуін санау

Формула мәтіні:

=ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"у";""))

This post is also available in RU.