Features of !SEMTools

Excel бағдарламасында жиілік сөздігін қалай жасауға болады?

Іздеу жарнамасы мен SEO үшін n-gram талдауы ең тиімді әдістердің бірі болып табылады. Алайда, алгоритмді жүзеге асырудың күрделілігіне байланысты n-gram анализі ұзақ уақыт бойы штатында программисті бар ірі агенттіктерге немесе бағдарламалау білімі бар озық мамандарға ғана қол жетімді болды.

Тәсілді танымал ету және оны Windows және Excel жүйесі бар кез келген адамға қол жетімді ету үшін Excel үшін !SEMTools ішінде n-gram талдау құралдары енгізілді. Әртүрлі талдау тәсілдері төменде схемалық мысалдармен берілген.

Барлық жағдайларда есептеу нәтижелері бар жеке парақ жасалады, бастапқы деректер ешқандай түрде өзгермейді.

Қарапайым n-грамдық талдау (пайда болу талдауы)

Бұл тәсіл ең қарапайым – N-грамм алынады және ол үшін оның мәтіндегі кездесуі талданады.

Сөздердің жиілігін талдау немесе мәтіндегі бірегей сөздерді санау және оларды пайда болуымен тізімде көрсету

Excel электрондық кестесінде сөздің неше рет кездесетінін қалай санауға болады? Егер біз тек бір сөзді іздейтін болсақ, COUNTIF формуласы көмектесе алады. Төмендегі формула олардың жағдайына қарамастан «сөз» таңбаларының тізбегі кездесетін жолдар санын есептейді.

=СЧЁТЕСЛИ(A1:A100;"*слова*")

Жұлдызша таңбасы көрсетілген таңбалар тізбегінің алдында және одан кейін кез келген басқа таңбалардың болуы немесе болмауы мүмкін екенін көрсетеді. Осыған байланысты «сөздік», «сөздік» т.б сөздері бар жолдарды есепке алуға болады. Сөздерді дәл сәйкестік бойынша табу үшін бағандағы барлық ұяшықтардың басына және соңына бос орын таңбасын қосып, бос орындарды қоса санауды пайдалану керек:

=СЧЁТЕСЛИ(A1:A100;"* слова *")

Бірақ бұл шешімнің өзі бізді барлық қайталауларды санағымыз келсе, сөз 2 немесе одан да көп рет қайталанатын жағдайлардан құтқара алмайды. Өйткені Формула жолдарды санайды.

Сондықтан, бұл тапсырманы оңай орындайтын !SEMTools ішінде макрос іске асырылды.

Мәтінді бөлектеңіз, сөздерді таңдаңыз, аяқтадыңыз. Мәтін не 5 жолдан, не миллион жолдан тұруы мүмкін – процедура секундтарды алады. Ең бастысы, мәтінде 1048575 бірегей сөзден артық болмауы керек – әйтпесе олар парақта көрсетілмейді. Бірақ мұндай жағдай сирек кездеседі.

Әртүрлі сөз формалары жеке сөздер ретінде қарастырылатынын атап өтуге болады, сондықтан сөз формаларын есепке алмай-ақ кездесуді талдау қажет болса, алдымен мәтін лемматизациялануы керек. Сонда сіз сөздердің жиілік сөздігін ғана емес, леммалардың жиілік сөздігін құрастырасыз.

1-gram-1

Биграммалардың пайда болуын талдау (2-грамм)

Алдыңғыға ұқсас, бірақ диаграммалар алынады – екі сөздің тізбегі. Бұл жағдайда триграммаларды қалай есептеу керек және т.б., қазірдің өзінде түсінікті сияқты.

1-gram-2

Жиілікпен n-граммдық талдау

Мәтін сөз тіркестерінен тұратын болса және әрбір сөз тіркесі үшін белгілі бір метрика белгілі болса (іздеу жарнамасында бұл жиілік), әрбір сөз формасының немесе лемманың салмағын сенімдірек өлшеу үшін бұл метриканы қазірдің өзінде талдау қажет.

!SEMTools ішінде бұл әдепкі бойынша ендірілген – пайдаланылған метрика бағанымен бірге екі бағанды ​​таңдау керек. Сол сияқты биграмма, триграмма және т.б жиіліктерді құрастыруға болады.

n-gram-2

Бірнеше метрика бойынша N-грамды талдау

Бұл тәсіл PPC мамандарына CTR, CPC, CPA, CR, AOV, ROAS және т.б. сияқты есептелген көрсеткіштерді талдау үшін пайдалы болады. Оларды есептеу үшін бірнеше метрика пайдаланылғандықтан, бұл көрсеткіштердің n-грамдық талдауын орындауға және есептелген көрсеткіштерді n-грамм контекстінде есептеуге болады.

n-gram-3
Біз жеке сөздерді өнімділік көрсеткіштеріне қарай бағалаймыз

Мұндай аналитика көптеген пайдалы түсініктерді бере алады. Мысалы, олар бойынша кейіннен қарқынды сауда жасау үшін жоғары түрлендіретін байланыстырушы сөздерді анықтаңыз. Немесе, керісінше, оларды жарнамадан шығару үшін төмен түрлендіретін сілтемелерді анықтау, ал олар жасалған сөздер, орташа алғанда, ауруханада төмен конверсиямен ерекшеленбеді.

n-gram-4
Сөз тіркестерінің тиімділігінің есептелген көрсеткіштерін абсолютті көрсеткіштер жиынтығы және олардың мәндері арқылы өлшейміз

Қорытынды

Жоғарыда келтірілген мысалдар іздеу сұрауларын немесе кілт сөздерді ғана емес, сонымен қатар ұзындығына қарамастан кіріс ретінде берілетін кез келген мәтінді талдауға мүмкіндік береді. Сізге тек қосымша бос орындарды алып тастау керек, барлық мәтінді кіші әріптерге түрлендіру керек және сіз талдау жасай аласыз.

Сұрақтарыңыз болса, авторлық арнаға жазылыңыз және чатта сұрақтар қойыңыз: https://t.me/semtoolschat

This post is also available in RU.