Функция СЦЕПИТЬ — простейшие примеры
Раздел функцийТекстовые
Название на английскомCONCATENATE
ВолатильностьНе волатильная
Похожие функции !SEMToolsJoinCells

Что делает функция СЦЕПИТЬ?

Функция производит операцию конкатенации.

Конкатенация — это объединение нескольких текстовых значений в одно, иначе выражаясь, сцепка текстовых фрагментов. Отсюда и название функции — СЦЕПИТЬ.

Синтаксис

=СЦЕПИТЬ(Текст1;Текст2;Текст3...)

Аргументы функции могут быть как ссылками на ячейки, так и вручную вводимые значения.

Примеры применения

Обычно функция СЦЕПИТЬ используется, когда несколько переменных находятся в отдельных ячейках, а результат должен выглядеть как единое предложение для простоты восприятия.

Это могут быть различные документы, отчеты и т.д.

Сотрудник отдела кадров использует готовый шаблон заявления на отпуск, в котором за пределами области печати выведены списком поля, в которых сотрудники чаще всего допускают ошибки при написании. Вид отпуска, даты начала и конца, количество дней между ними.

Количество дней высчитывается автоматически.

Функция СЦЕПИТЬ позволяет вставить текст переменных в основной текст документа. Кадровику остается только вывести документ на печать.

Сцепить даты в Excel

Многим известно, что даты при обработке текстовыми функциями преобразуются в целое число, что мешает их вставке в текст.

Все дело в том, что отдельных форматов для дат в Excel нет, и это действительно числа. Которые, более того, можно написать десятками способов.

Чтобы дата приобрела стала текстом и получила нужное форматирование, поможет функция ТЕКСТ. Она преобразует числовые значения в различные представления в текстовом формате — проценты, даты, дату-время или время.

Краткая запись даты в виде хх.хх.хх г. выглядела бы так:

=ТЕКСТ(M4;"дд.ММ.гг")&" г."

Но в данном случае нужно отображать полную дату, а месяц в дате в родительном падеже.

При таком условии формула для преобразования функцией текст выглядит так:

=ТЕКСТ(M4;"[$-FC19]дд ММММ гггг")&" г."

Посмотреть эту и другие формулы (двойной клик по ячейке отобразит содержимое), а также скачать сам файл-пример, можно далее: