Возможности !SEMTools

Подсчет количества символов в нескольких ячейках Excel

Посчитать символы в ячейках Excel довольно просто, если нет никаких дополнительных условий. Но как только они возникают, могут понадобиться сложные составные формулы и дополнительные знания.

Итак, обо всем по порядку.

Посчитать количество знаков в ячейках столбца Excel

Наиболее простая задача, которую можно решить несколькими способами. Можно посчитать знаки в каждой из ячеек и далее просуммировать, можно использовать формулу массива, которая выведет сумму сразу.

Формула — количество знаков в ячейке

Чтобы посчитать все символы, включая пробелы, в одной ячейке, поможет текстовая функция ДЛСТР:

 =ДЛСТР(A1)
Посчитать символы в ячейках с помощью функции ДЛСТР

Осталось просуммировать данные в столбце D, чтобы получить количество знаков во всех ячейках.

Подсчет количества символов в тексте Excel — формула массива

Решение в предыдущем разделе требует создания отдельного столбца с данными. Можно ли обойтись без него?

Да, и здесь нам поможет формула массива:

 {=СУММ(ДЛСТР(Диапазон-ячеек))}
Подсчет символов в диапазоне Excel

Что происходит на данной картинке? Если в двух шагах, то:

  1. функция ДЛСТР, обращаясь к диапазону ячеек, создает в памяти компьютера массив числовых значений длин каждой ячейки
  2. Функция СУММ суммирует эти значения и выводит результат.

Обратите внимание, эту формулу, как и все формулы массива, нужно вводить сочетанием клавиш Ctrl+Shift+Enter, и если этого не сделать, она вернет только длину первой ячейки, т.к. массив не будет создан.


Предыдущая статья о формулах массива:

Учимся формулам массива 1/4:

Как создать алфавит в Excel

Следующая статья о формулах массива:

Учимся формулам массива 3/4:

Извлечь текст до первой цифры в ячейке