Возможности !SEMTools

Посчитать количество символов в ячейках Excel

Подсчет количества символов в ячейках Excel бывает очень полезен — вопрос лишь в том, какой конкретно алгоритм использовать. А это в свою очередь зависит от ситуации и условий поставленной задачи.

Когда нужен подсчет символов в ячейках

Наиболее часто количество всех или определенных символов в ячейке нужно знать, когда есть какие-либо ограничения:

  • количество символов в каждой ячейке не должно превышать определенное значение
  • нет ограничений по длине на одну ячейку, но есть лимит на суммарное количество символов в нескольких
  • когда есть ограничение по количеству символов снизу, иначе говоря, минимальная длина
  • есть ограничение по количеству введенных в ячейку определенных символов (например, не более одного знака «!»)

Ниже я рассмотрю более детально каждый из случаев.

Посчитать количество символов каждой ячейки

Можно воспользоваться как формулой, так и процедурами Excel

Количество символов в ячейке — формула

ДЛСТР — замечательная функция, и с её помощью можно решить уйму задач связанных с подсчетом символов в ячейках. Вот простейший пример ее применения.

Формула выглядит так:

=ДЛСТР(A1)

формула количества символов в ячейке
Результат работы формулы

Процедура подсчета символов в ячейках

Поскольку ввод формул — занятие муторное, я разработал для этой задачи несложную процедуру в своей надстройке для Excel. Прелесть процедуры в том, что она считает все моментально в пару кликов и выводит результат в столбец справа (если активна опция вывода в соседний столбец).

Можно выделять целиком весь столбец, надстройка сама определит конец рабочего диапазона:

Подсчет количества символов в нескольких ячейках процедурой !SEMTools

Посчитать количество символов в нескольких ячейках одновременно

Если нет задачи считать длину содержимого каждой из ячеек, а нужна сразу сумма длин, можно использовать ту же функцию ДЛСТР, но в несколько ином виде — в виде формулы массива:

Формула подсчета суммарной длины содержимого нескольких ячеек в символах

Текст формулы:

=СУММ(ДЛСТР(A2:A6))

Важно понимать, что формула вернет корректный результат, только если обретет фигурные скобки после ввода ее в ячейку сочетанием клавиш Ctrl + Shift + Enter

Посчитать, сколько раз встречается определенный символ в ячейке

Если посчитать разницу длин ячейки с определенным символом и той же ячейки, но без него — мы получим встречаемость этого символа в ячейке.

Удалить символ нам поможет функция ПОДСТАВИТЬ, а вот составная формула на примере подсчета в ячейках буквы «у»:

Пример - ДЛСТР для подсчета встречаемости буквы в ячейке
Подсчет встречаемости буквы «у» в ячейке

Текст формулы:

=ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"у";""))